Some problems with droseras


Recommended Posts

Hi All,

I recently bought a new peat which should be better that me previous one. Previous peat is quite quickly covered with green algae and moss. It was very annoying.

I planted seeds of several species, they grew up ok and continue growing but very very slowly. At the same time I bought Drosera capensis var. alba and typical form, Drosera rotundifolia. It's been 1 month already and they look sick... 

Drosera rotundifolia after several days since planting.

51075038553_058a18643b_o.jpg

The same plants since 1 month from planting.

51075022583_129eb7059f_o.jpg

 

Drosera capensis are without any change... They grow very slowly and their leaves constantly turn black.

 

51006535780_2a4d7f604b_o.jpg

 

I use soil: peat:sand 1:1. Water and lighting are ok.

Regarding my seedlings... They doesn't die but grow very slowly:

3 month since sowing:

51075717636_677befcf48_o.jpg

51075717731_4a1d30f5ed_o.jpg

 

Note that there are no any algae or moss. It tells us that the peat should not have nutrients.

 

Also I would like to show my friend's drosera aliciae that are in the same peat and sand. Also has sick red color and black growing point:

51075862157_1e6b6015be_o.jpg

 

Have somebody faced with such issues?

Link to post
Share on other sites

do you read the declaration of your peat? Its a small area on the pack. Is it fertilized?

It should be H2-H5 (better H4)

pH 2,5-4

And no fertilized! Some garden peat its possible, they have incl. fertilizer!

Which water do you use?

regards

Tobias

Edited by Tobias Kulig
Link to post
Share on other sites

I bought the peat with simple white pack without any declaration. The seller told me that the peat is not fertilized. 2.5-3.5 Ph.

I have checked it with my TDS and PH meters. My results: 77 ppm and 3.7 PH. As far as I understand it is Ok results.

I use distilled water. To be briefly: all conditions for the plants are OK. But I am not convinced that the peat is ok. As you can see my sundews have sick red color... I don't think that is can be related to too much watering.

Link to post
Share on other sites

Maybe you put too much emphasis on the algal/moss development to decide whether a substrate is of good quality or not.

I think the key question would be: what is special in your new peat that does not allow algae/mosses to grow? I have got moss growth even in sterilized peat given enough time (so spores can reach the place) and favourable conditions for its development. If I get a peat that is not colonized by mosses at all (in places where moss is favored to grow), I would be suspicious...

Link to post
Share on other sites

Hm. It makes sense but I am not sure that I can check it any way.

I've just ordered a new good checked peat from Russia. It may sound ridiculous, but it is difficult to find good peat in Belarus. I hope it helps save my plants. I will try to repot all plant from the peat to a new one from Russia.

Link to post
Share on other sites
4 minutes ago, Guy said:

Why do you have soil in your mix?  Nutrient free peat and sand or vermiculite should be OK.

Guy

I use substrate which contains of peat and sand. Looks like I was faced with bad peat for CPs.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.